<!DOCTYPE html>
<html lang="en-GB" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.rossiterandco.com/xmlrpc.php" />


<!--[if lt IE 9]>
	<script src="https://www.rossiterandco.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://www.rossiterandco.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->

<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Discover what’s available on our huge business video production site - Studio Rossiter</title>
<meta name="description" content="Discover what’s available on our huge video production site. With over 1,260 pages and 100 video samples available this little Intro Video should add some light to your journey."/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/" />
<meta property="og:locale" content="en_GB">
<meta property="og:type" content="article">
<meta property="og:title" content="Discover what’s available on our huge business video production site - Studio Rossiter">
<meta property="og:description" content="Discover what’s available on our huge video production site. With over 1,260 pages and 100 video samples available this little Intro Video should add some light to your journey.">
<meta property="og:url" content="https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/">
<meta property="og:site_name" content="Studio Rossiter">
<meta property="article:publisher" content="https://www.facebook.com/rossitercovideo">
<meta property="article:tag" content="intro video">
<meta property="article:section" content="Video">
<meta property="og:updated_time" content="2021-02-05T14:25:01+00:00">
<meta property="og:image" content="https://www.rossiterandco.com/wp-content/uploads/2021/02/discover-what-is-available-on-our-huge-business-video-production-site-compressort.png">
<meta property="og:image:secure_url" content="https://www.rossiterandco.com/wp-content/uploads/2021/02/discover-what-is-available-on-our-huge-business-video-production-site-compressort.png">
<meta property="og:image:width" content="1000">
<meta property="og:image:height" content="562">
<meta property="og:image:alt" content="Discover what’s available on our huge business video production site">
<meta property="og:image:type" content="image/png">
<meta property="article:published_time" content="2021-02-05GMT10:00:00+00:00">
<meta property="article:modified_time" content="2021-02-05GMT14:25:01+00:00">
<meta property="og:video" content="https://player.vimeo.com/video/486323650?color&amp;autopause=1&amp;loop=0&amp;muted=0&amp;title=0&amp;portrait=0&amp;byline=0#t=">
<meta property="video:duration" content="54">
<meta property="article:published_time" content="2021-02-05GMT10:00:00+00:00">
<meta property="article:modified_time" content="2021-02-05GMT14:25:01+00:00">
<meta property="og:video" content="https://player.vimeo.com/video/470529471?color&amp;autopause=1&amp;loop=0&amp;muted=0&amp;title=0&amp;portrait=0&amp;byline=0#t=">
<meta property="ya:ovs:upload_date" content="2020-12-02 04:47:52">
<meta property="ya:ovs:allow_embed" content="true">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Discover what’s available on our huge business video production site - Studio Rossiter">
<meta name="twitter:description" content="Discover what’s available on our huge video production site. With over 1,260 pages and 100 video samples available this little Intro Video should add some light to your journey.">
<meta name="twitter:site" content="@Rossiterandco">
<meta name="twitter:creator" content="@Rossiterandco">
<meta name="twitter:image" content="https://www.rossiterandco.com/wp-content/uploads/2021/02/discover-what-is-available-on-our-huge-business-video-production-site-compressort.png">
<script type="application/ld+json" class="rank-math-schema-pro">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</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Studio Rossiter &raquo; Feed" href="https://www.rossiterandco.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Studio Rossiter &raquo; Comments Feed" href="https://www.rossiterandco.com/comments/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rossiterandco.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='grw_css-css'  href='https://www.rossiterandco.com/wp-content/plugins/google-reviews-business/static/css/google-review.css?ver=5.6' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.rossiterandco.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://www.rossiterandco.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.6' media='all' />
<link rel='stylesheet' id='font-awesome-5-css'  href='https://www.rossiterandco.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.1/css/all.min.css?ver=2.4.2' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.rossiterandco.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.1/css/v4-shims.min.css?ver=2.4.2' media='all' />
<link rel='stylesheet' id='fl-builder-layout-19357-css'  href='https://www.rossiterandco.com/wp-content/uploads/bb-plugin/cache/19357-layout.css?ver=db4e2b056bdca6d8295f097cf34de36f' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.rossiterandco.com/wp-includes/css/dashicons.min.css?ver=5.6' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://www.rossiterandco.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=7.0.2' media='all' />
<link rel='stylesheet' id='bellows-css'  href='https://www.rossiterandco.com/wp-content/plugins/bellows-pro/pro/assets/css/bellows.min.css?ver=1.2.1' media='all' />
<link rel='stylesheet' id='bellows-blue-material-css'  href='https://www.rossiterandco.com/wp-content/plugins/bellows-pro/assets/css/skins/blue-material.css?ver=1.2.1' media='all' />
<link rel='stylesheet' id='bellows-vanilla-css'  href='https://www.rossiterandco.com/wp-content/plugins/bellows-pro/assets/css/skins/vanilla.css?ver=1.2.1' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://www.rossiterandco.com/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.min.css?ver=2.4.2' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.rossiterandco.com/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.7.7' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://www.rossiterandco.com/wp-content/uploads/bb-theme/skin-5fc94b481382a.css?ver=1.7.7' media='all' />
<link rel='stylesheet' id='fl-child-theme-css'  href='https://www.rossiterandco.com/wp-content/themes/bb-theme-child/style.css?ver=5.6' media='all' />
<link rel='stylesheet' id='pp-animate-css'  href='https://www.rossiterandco.com/wp-content/plugins/bbpowerpack/assets/css/animate.min.css?ver=3.5.1' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-1cceebde7d90c184febadf366aba7581-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%2C400%2C700&#038;ver=5.6' media='all' />
<script src='https://www.rossiterandco.com/wp-content/plugins/google-reviews-business/static/js/wpac-time.js?ver=5.6' id='wpac_time_js-js'></script>
<script src='https://www.rossiterandco.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script src='https://www.rossiterandco.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script src='https://www.rossiterandco.com/wp-includes/js/imagesloaded.min.js?ver=5.6' id='imagesloaded-js'></script>
<link rel="https://api.w.org/" href="https://www.rossiterandco.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rossiterandco.com/wp-json/wp/v2/posts/19357" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rossiterandco.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rossiterandco.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://www.rossiterandco.com/?p=19357' />
<link rel="alternate" type="application/json+oembed" href="https://www.rossiterandco.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rossiterandco.com%2Fvideo%2Fdiscover-what-is-available-on-our-huge-business-video-production-site%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rossiterandco.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rossiterandco.com%2Fvideo%2Fdiscover-what-is-available-on-our-huge-business-video-production-site%2F&#038;format=xml" />
		<script>
			var bb_powerpack = {
				ajaxurl: 'https://www.rossiterandco.com/wp-admin/admin-ajax.php'
			};
		</script>
		<style id="bellows-custom-generated-css">
/** Bellows Custom Menu Styles (Customizer) **/
/* main */
.bellows.bellows-main, .bellows.bellows-main .bellows-menu-item, .bellows.bellows-main .bellows-menu-item .bellows-target { font-family:"Open Sans", sans-serif; }
.bellows.bellows-main .bellows-nav .bellows-item-level-0 > .bellows-target:hover { background-color:#07a6eb; color:#ffffff; }
.bellows.bellows-main .bellows-nav .bellows-item-level-0.bellows-active > .bellows-target { background-color:#07a6eb; color:#ffffff; }
.bellows.bellows-main .bellows-nav .bellows-item-level-0.bellows-current-menu-item > .bellows-target, .bellows.bellows-main .bellows-nav .bellows-item-level-0.bellows-current-menu-ancestor > .bellows-target { background-color:#07a6eb; color:#ffffff; }
.bellows.bellows-main .bellows-nav .bellows-item-level-0 > .bellows-target, .bellows.bellows-main .bellows-nav .bellows-item-level-0 > .bellows-custom-content { color:#7a7a7a; border-bottom-color:#89d3ff; }
.bellows.bellows-main .bellows-nav .bellows-item-level-0 > .bellows-target { font-weight:bold; }
.bellows.bellows-main .bellows-nav .bellows-submenu { background-color:#d6f3ff; }
.bellows.bellows-main .bellows-nav .bellows-submenu .bellows-target:hover { background-color:#07a6eb; color:#ffffff; }
.bellows.bellows-main .bellows-nav .bellows-submenu .bellows-current-menu-item > .bellows-target, .bellows.bellows-main .bellows-nav .bellows-submenu .bellows-current-menu-ancestor > .bellows-target { background-color:#d6f3ff; color:#3f3f3f; }
.bellows.bellows-main .bellows-nav .bellows-submenu .bellows-target { color:#3f3f3f; }
.bellows.bellows-main .bellows-nav .bellows-submenu .bellows-menu-item > .bellows-target, .bellows.bellows-main .bellows-nav .bellows-submenu .bellows-menu-item > .bellows-subtoggle { font-size:14px; }
.bellows.bellows-main .bellows-nav .bellows-submenu .bellows-menu-item > .bellows-target { padding:20px 20px 20px 36px; }


/** Bellows Custom Menu Item Styles (Menu Item Settings) **/
/* 13108 */ .bellows .bellows-nav .bellows-menu-item.bellows-menu-item-13108 > .bellows-target { color:#dd3333; }

/* Status: Loaded from Transient */

</style>		<style id="wp-custom-css">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</style>
		<style type="text/css">/** Mega Menu CSS: fs **/</style>
<meta name="google-site-verification" content="yaksu5foUFGL6QQFfaRT1cEr8uSE2dG8cqPiGd7t65I" />
<link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet">

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-T43GPZP');</script>
<!-- End Google Tag Manager -->

<script>	
function init() {
  var vidDefer = document.getElementsByTagName('iframe');
  for (var i=0; i<vidDefer.length; i++) {
    if(vidDefer[i].getAttribute('data-src')) {
      vidDefer[i].setAttribute('src',vidDefer[i].getAttribute('data-src'));
} } }
window.onload = init;
</script>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"hFtgu1WyR620WR", domain:"rossiterandco.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=hFtgu1WyR620WR" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  
	
</head>

<body class="post-template-default single single-post postid-19357 single-format-standard fl-builder fl-framework-bootstrap fl-preset-modern fl-full-width fl-has-sidebar fl-nav-mobile-offcanvas fl-offcanvas-overlay-right fl-fixed-header fl-submenu-indicator fl-nav-collapse-menu" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<link rel="icon" type="image/x-icon" href="https://rossiterandco.com/favicon.ico" />
<a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div class="fl-page">
	<div class="fl-page-bar">
	<div class="fl-page-bar-container container">
		<div class="fl-page-bar-row row">
			<div class="col-md-12 text-right clearfix" style="padding-right: 22px;">		<nav class="top-bar-nav" aria-label="Top Bar Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"			role="navigation">
			<ul id="menu-top-bar" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-18459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18459 nav-item"><a href="#searchwp-modal-652ea0d21b1427a1bfa685e40d9bc1de" class="nav-link" data-searchwp-modal-trigger="searchwp-modal-652ea0d21b1427a1bfa685e40d9bc1de"><i class="fa fa-search" aria-hidden="true"></i></a></li>
<li id="menu-item-18476" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18476 nav-item"><a class="nav-link">HELP CENTRE</a>
<ul class="sub-menu"><li id="menu-item-18513" class="title-upper-top-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-18513 nav-item"><a href="https://help.rossiterandco.com" class="nav-link">Help Centre</a></li>
	<li id="menu-item-18481" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18481 nav-item"><a href="https://www.rossiterandco.com/masterclass/" class="nav-link">Video Masterclass</a></li>
	<li id="menu-item-18477" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18477 nav-item"><a href="https://www.rossiterandco.com/video-production-resources/" class="nav-link">Video Production Resources</a></li>
	<li id="menu-item-18478" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18478 nav-item"><a href="https://www.rossiterandco.com/corporate-video-production/" class="nav-link">Understanding Video Costs</a></li>
	<li id="menu-item-18479" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18479 nav-item"><a href="https://www.rossiterandco.com/company-video-handbook/" class="nav-link">Company Video Handbook</a></li>
	<li id="menu-item-18480" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18480 nav-item"><a href="https://www.rossiterandco.com/foreign-language-video-why-bother/" class="nav-link">Foreign Language Video Productions</a></li>
</ul></li>
<li id="menu-item-18461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18461 nav-item"><a href="https://www.rossiterandco.com/blog/" class="nav-link">BLOG</a></li>
<li id="menu-item-18463" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18463 nav-item"><a class="nav-link">ABOUT US</a>
<ul class="sub-menu"><li id="menu-item-18464" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18464 nav-item"><a href="https://www.rossiterandco.com/company/" class="nav-link">Company</a></li>
	<li id="menu-item-18466" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18466 nav-item"><a href="https://www.rossiterandco.com/a-radical-video-strategy-to-win-more-customers/" class="nav-link">A Radical Video Strategy</a></li>
	<li id="menu-item-18465" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18465 nav-item"><a href="https://www.rossiterandco.com/whats-in-and-whats-out-in-video-marketing/" class="nav-link">Marketing Video Manifesto</a></li>
	<li id="menu-item-18467" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18467 nav-item"><a href="https://www.rossiterandco.com/clients/" class="nav-link">Clients</a></li>
	<li id="menu-item-18468" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18468 nav-item"><a href="https://www.rossiterandco.com/testimonials/" class="nav-link">Testimonials</a></li>
	<li id="menu-item-18469" class="title-upper-top-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-18469 nav-item"><a href="https://www.rossiterandco.com/the-creative-process-explainer-video/" class="nav-link">Creative Process</a></li>
</ul></li>
<li id="menu-item-18453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18453 nav-item"><a href="https://www.rossiterandco.com/customer-contact-form/" class="nav-link">CONTACT</a></li>
</ul></nav></div>					</div>
	</div>
</div><!-- .fl-page-bar -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-sm-10 col-md-4 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://www.rossiterandco.com/" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png" data-retina="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-retina-600-grey.png" title="" alt="Studio Rossiter" /><meta itemprop="name" content="Studio Rossiter" /></a>
											</div>
				</div>
				<div class="col-sm-12 col-md-12 fl-page-nav-col">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default navbar-expand-md" style="float: left !important;" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span><i class="fas fa-bars" aria-hidden="true"></i><span class="sr-only">Menu</span></span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-main" class="nav navbar-nav navbar-right menu fl-theme-menu"><li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14 nav-item"><a class="nav-link">Marketing</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-18665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18665 nav-item"><a href="https://www.rossiterandco.com/software-demo-video-production/" class="nav-link">Software demo video</a></li>
	<li id="menu-item-18960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18960 nav-item"><a href="https://www.rossiterandco.com/animated-video-production-services/" class="nav-link">Animated Video Production</a></li>
	<li id="menu-item-11459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11459 nav-item"><a href="https://www.rossiterandco.com/explainer-video-production-services/" class="nav-link">LOW COST EXPLAINER VIDEO</a></li>
	<li id="menu-item-12862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12862 nav-item"><a href="https://www.rossiterandco.com/filmed-video-production-services/" class="nav-link">FILMED &#038; STOCK VIDEO</a></li>
	<li id="menu-item-16223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16223 nav-item"><a href="https://www.rossiterandco.com/social-media-video-production/" class="nav-link">Social media video</a></li>
</ul>
</li>
<li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15 nav-item"><a class="nav-link">Training</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-16742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16742 nav-item"><a href="https://www.rossiterandco.com/low-cost-animated-safety-video/" class="nav-link">Low cost animated safety video</a></li>
	<li id="menu-item-751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-751 nav-item"><a href="https://www.rossiterandco.com/contractor-induction-video-production-services/" class="nav-link">Contractor induction video</a></li>
	<li id="menu-item-752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-752 nav-item"><a href="https://www.rossiterandco.com/animated-safety-video-production-services/" class="nav-link">Custom Animated safety video</a></li>
	<li id="menu-item-748" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-748 nav-item"><a href="https://www.rossiterandco.com/health-and-safety-video-production-services/" class="nav-link">Health &#038; safety video</a></li>
	<li id="menu-item-749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-749 nav-item"><a href="https://www.rossiterandco.com/training-video-production-services/" class="nav-link">Training video</a></li>
	<li id="menu-item-750" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-750 nav-item"><a href="https://www.rossiterandco.com/retail-training-video-production-services/" class="nav-link">Retail training video</a></li>
	<li id="menu-item-762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-762 nav-item"><a href="https://www.rossiterandco.com/software-tutorial-video-production-services/" class="nav-link">Software tutorial video</a></li>
	<li id="menu-item-753" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-753 nav-item"><a href="https://www.rossiterandco.com/training-multimedia-production-services/" class="nav-link">Training multimedia production</a></li>
	<li id="menu-item-7601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7601 nav-item"><a href="https://www.rossiterandco.com/foreign-language-safety-video-production-services/" class="nav-link">Foreign language safety video</a></li>
</ul>
</li>
<li id="menu-item-14324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14324 nav-item"><a class="nav-link">Pricing</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-19082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19082 nav-item"><a href="https://www.rossiterandco.com/marketing-video-production-price-list/" class="nav-link">Marketing video price list</a></li>
	<li id="menu-item-14410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14410 nav-item"><a href="https://www.rossiterandco.com/training-video-production-prices/" class="nav-link">Training video price list</a></li>
	<li id="menu-item-18460" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18460 nav-item"><a href="https://www.rossiterandco.com/special-video-deal-for-technology-marketers/" class="nav-link">The Deal</a></li>
</ul>
</li>
<li id="menu-item-17523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17523 nav-item"><a class="nav-link">Portfolio</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-17521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17521 nav-item"><a href="https://www.rossiterandco.com/video-portfolio/" class="nav-link">Portfolio</a></li>
	<li id="menu-item-17520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17520 nav-item"><a href="https://www.rossiterandco.com/video-marketing-campaign-examples/" class="nav-link">Campaigns</a></li>
</ul>
</li>
<li id="menu-item-16" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16 nav-item"><a class="nav-link">Industries</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-761" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-761 nav-item"><a href="https://www.rossiterandco.com/technology-systems-video-production-services/" class="nav-link">Technology | Tech industry</a></li>
	<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757 nav-item"><a href="https://www.rossiterandco.com/factory-video-production-services/" class="nav-link">Factory | Manufacturing</a></li>
	<li id="menu-item-755" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-755 nav-item"><a href="https://www.rossiterandco.com/financial-banking-video-production-services/" class="nav-link">Financial | Banking</a></li>
	<li id="menu-item-758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-758 nav-item"><a href="https://www.rossiterandco.com/international-video-production-services/" class="nav-link">International</a></li>
	<li id="menu-item-759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-759 nav-item"><a href="https://www.rossiterandco.com/healthcare-video-production-services/" class="nav-link">Medical | Healthcare</a></li>
	<li id="menu-item-760" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-760 nav-item"><a href="https://www.rossiterandco.com/construction-video-production-services/" class="nav-link">Construction | Civils</a></li>
	<li id="menu-item-763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-763 nav-item"><a href="https://www.rossiterandco.com/accident-video-production-services/" class="nav-link">Accident video</a></li>
</ul>
</li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div class="fl-page-content" itemprop="mainContentOfPage">

		
<div class="container">
	<div class="row">
		
				
		<div class="fl-content fl-content-left col-md-8">
							<article class="fl-post post-19357 post type-post status-publish format-standard hentry category-video tag-intro-video" id="fl-post-19357" itemscope itemtype="https://schema.org/BlogPosting">

	
	<header class="fl-post-header" role="banner">
		<h1 class="fl-post-title" itemprop="headline">
			Discover what’s available on our huge business video production site					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://www.rossiterandco.com/author/kevin-rossiter/"><span>Kevin Rossiter</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date">5th February 2021</span></div><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/" content="Discover what’s available on our huge business video production site" /><meta itemprop="datePublished" content="2021-02-05" /><meta itemprop="dateModified" content="2021-02-05" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Studio Rossiter"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.rossiterandco.com/author/kevin-rossiter/" /><meta itemprop="name" content="Kevin Rossiter" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

	
	
	<div class="fl-post-content clearfix" itemprop="text">
		<div class="fl-builder-content fl-builder-content-19357 fl-builder-content-primary fl-builder-global-templates-locked" data-post-id="19357"><div class="fl-row fl-row-fixed-width fl-row-bg-none fl-node-5f27eb5e3ac23" data-node="5f27eb5e3ac23">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f27eb5e69f81" data-node="5f27eb5e69f81">
			<div class="fl-col fl-node-5f27eb5e6a094" data-node="5f27eb5e6a094">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-pp-video fl-node-5f27eb5e3a3de" data-node="5f27eb5e3a3de">
	<div class="fl-module-content fl-node-content">
		
<div class="pp-video-wrapper pp-aspect-ratio-169">
		<div class="pp-fit-aspect-ratio">
	<iframe class="pp-video-iframe" allowfullscreen allow="autoplay" src="https://player.vimeo.com/video/506164327?color&amp;autopause=1&amp;loop=0&amp;muted=0&amp;title=0&amp;portrait=0&amp;byline=0#t="></iframe>	</div>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-fixed-width fl-row-bg-none fl-node-5e1f360a4eda0" data-node="5e1f360a4eda0">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f27ebbe28a25" data-node="5f27ebbe28a25">
			<div class="fl-col fl-node-5f27ebbe28ad0" data-node="5f27ebbe28ad0">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f27ebbe289cb" data-node="5f27ebbe289cb">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>How many websites have you been to where there was a video outlining what was available on the site? Maybe none?</p>
<p>Or how many sites have you seen where you quickly got lost in a snowstorm of choices and didn’t know what to click next?</p>
<p>Or sites where you just couldn’t find what you wanted, even though it was probably there?</p>
<p>It all adds up to a big time-waste on your part, clicking and clicking before giving up and going elsewhere.</p>
<p>Maybe you deserve a dedicated Intro Video, one to highlight the scope of what’s available so that in under a minute you can tell if you’re in the right place or not.</p>
<p>Hope you like our offering. Thanks.</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-fixed-width fl-row-bg-none fl-node-5e2ee6cb1eb52" data-node="5e2ee6cb1eb52">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5e2ee32bd5b1c" data-node="5e2ee32bd5b1c">
			<div class="fl-col fl-node-5e2ee32bd5b56" data-node="5e2ee32bd5b56">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5e2ee32bd5bc3" data-node="5e2ee32bd5bc3">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<h3>HELP YOUR COLLEAGUES - SHARE THIS BLOG</h3>
</div>
	</div>
</div>
	</div>
</div>
			<div class="fl-col fl-node-5e2ee32bd5b8d fl-col-small" data-node="5e2ee32bd5b8d">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-pp-social-share fl-node-5e2ee32bd5bfa" data-node="5e2ee32bd5bfa">
	<div class="fl-module-content fl-node-content">
		<div class="pp-social-share-content pp-share-buttons-view-icon pp-share-buttons-skin-minimal pp-share-buttons-shape-square pp-social-share-col-0 pp-share-buttons-align-left pp-share-buttons-color-official">
	<div class="pp-social-share-inner">
			<div class="pp-share-grid-item">
			<div class="pp-share-button pp-share-button-email">
				<a class="pp-share-button-link" href="mailto:?body=https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/">
										<span class="pp-share-button-icon">
													<i class="fas fa-envelope" aria-hidden="true"></i>
												<span class="pp-screen-only">Share on Email</span>
					</span>
					
									</a>
			</div>
		</div>
			<div class="pp-share-grid-item">
			<div class="pp-share-button pp-share-button-facebook">
				<a class="pp-share-button-link" href="https://www.facebook.com/sharer.php?u=https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/&title=Discover+what%E2%80%99s+available+on+our+huge+business+video+production+site">
										<span class="pp-share-button-icon">
													<i class="fab fa-facebook" aria-hidden="true"></i>
												<span class="pp-screen-only">Share on Facebook</span>
					</span>
					
									</a>
			</div>
		</div>
			<div class="pp-share-grid-item">
			<div class="pp-share-button pp-share-button-twitter">
				<a class="pp-share-button-link" href="https://twitter.com/intent/tweet?url=https://www.rossiterandco.com/video/discover-what-is-available-on-our-huge-business-video-production-site/&text=Discover+what%E2%80%99s+available+on+our+huge+business+video+production+site">
										<span class="pp-share-button-icon">
													<i class="fab fa-twitter" aria-hidden="true"></i>
												<span class="pp-screen-only">Share on Twitter</span>
					</span>
					
									</a>
			</div>
		</div>
		</div>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5e2ee6d2947b3" data-node="5e2ee6d2947b3">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5e2ee2795365d" data-node="5e2ee2795365d">
			<div class="fl-col fl-node-5e2ee2795376c" data-node="5e2ee2795376c">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5e2ee279535b0" data-node="5e2ee279535b0">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>recent posts</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>

<div class="fl-col-group fl-node-5e29e4284c6aa" data-node="5e29e4284c6aa">
			<div class="fl-col fl-node-5e29e4284c71a" data-node="5e29e4284c71a">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-pp-content-grid fl-node-5e29e4284c750" data-node="5e29e4284c750">
	<div class="fl-module-content fl-node-content">
		<div class="pp-posts-wrapper">
	
	<div class="pp-content-posts">
		<div class="pp-content-post-grid pp-equal-height clearfix" itemscope="itemscope" itemtype="https://schema.org/Blog">
			
				
<div class="pp-content-post pp-content-grid-post pp-grid-style-3 post-18798 post type-post status-publish format-standard has-post-thumbnail hentry category-video tag-software-demo-video-cost tag-software-demo-video-prices" itemscope itemtype="https://schema.org/BlogPosting" data-id="18798">

	<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.rossiterandco.com/video/what-does-a-software-demo-video-cost/" content="How to figure out your software demo video cost" /><meta itemprop="datePublished" content="2021-01-05" /><meta itemprop="dateModified" content="2021-02-04" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Studio Rossiter"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.rossiterandco.com/author/kevin-rossiter/" /><meta itemprop="name" content="Kevin Rossiter" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor.jpg" /><meta itemprop="width" content="1000" /><meta itemprop="height" content="563" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>
	
					<a class="pp-post-link" href="https://www.rossiterandco.com/video/what-does-a-software-demo-video-cost/" title="How to figure out your software demo video cost"></a>
		
		
		
					<div class="pp-content-grid-image pp-post-image">
    					<div class="pp-post-featured-img">
				<div class="fl-photo fl-photo-align-center" itemscope itemtype="https://schema.org/ImageObject">
	<div class="fl-photo-content fl-photo-img-jpg">
				<img loading="lazy" class="fl-photo-img wp-image-18900 size-medium" src="https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor-700x394.jpg" alt="How to figure out your software demo video cost" itemprop="image" data-no-lazy="1" height="394" width="700" title="how-to-figure-out-your-software-demo-video-cost-compressor" srcset="https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor-700x394.jpg 700w, https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor-768x432.jpg 768w, https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor-339x191.jpg 339w, https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" />
					</div>
	</div>
			</div>
		    
			
		
			</div>
		
		<div class="pp-content-grid-inner pp-content-body clearfix">
			
			
			<div class="pp-content-post-data">
									<h3 class="pp-content-grid-title pp-post-title" itemprop="headline">
														How to figure out your software demo video cost											</h3>
									
				
				
				
				
				
				
				
				
			</div>
			
					</div>

			</div>

<div class="pp-content-post pp-content-grid-post pp-post-2n pp-grid-style-3 post-18591 post type-post status-publish format-standard has-post-thumbnail hentry category-video tag-calculating-video-runtime-and-cost" itemscope itemtype="https://schema.org/BlogPosting" data-id="18591">

	<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.rossiterandco.com/video/video-5-bringing-your-technology-or-software-explainer-video-cost-estimates-together/" content="Video 5: Bringing your technology or software explainer video cost estimates together" /><meta itemprop="datePublished" content="2020-12-08" /><meta itemprop="dateModified" content="2021-01-22" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Studio Rossiter"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.rossiterandco.com/author/kevin-rossiter/" /><meta itemprop="name" content="Kevin Rossiter" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor.jpg" /><meta itemprop="width" content="1000" /><meta itemprop="height" content="562" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>
	
					<a class="pp-post-link" href="https://www.rossiterandco.com/video/video-5-bringing-your-technology-or-software-explainer-video-cost-estimates-together/" title="Video 5: Bringing your technology or software explainer video cost estimates together"></a>
		
		
		
					<div class="pp-content-grid-image pp-post-image">
    					<div class="pp-post-featured-img">
				<div class="fl-photo fl-photo-align-center" itemscope itemtype="https://schema.org/ImageObject">
	<div class="fl-photo-content fl-photo-img-jpg">
				<img loading="lazy" class="fl-photo-img wp-image-18553 size-medium" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor-700x393.jpg" alt="Video 5: Bringing your technology or software explainer video cost estimates together" itemprop="image" data-no-lazy="1" height="393" width="700" title="Video-5-Bringing-together-compressor" srcset="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor-700x393.jpg 700w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor-768x432.jpg 768w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor-339x191.jpg 339w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" />
					</div>
	</div>
			</div>
		    
			
		
			</div>
		
		<div class="pp-content-grid-inner pp-content-body clearfix">
			
			
			<div class="pp-content-post-data">
									<h3 class="pp-content-grid-title pp-post-title" itemprop="headline">
														Video 5: Bringing your technology or software explainer video cost estimates together											</h3>
									
				
				
				
				
				
				
				
				
			</div>
			
					</div>

			</div>

<div class="pp-content-post pp-content-grid-post pp-grid-style-3 post-18575 post type-post status-publish format-standard has-post-thumbnail hentry category-video tag-estimate-software-explainer-video-runtime tag-explainer-video-budget tag-write-a-draft-video-script" itemscope itemtype="https://schema.org/BlogPosting" data-id="18575">

	<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.rossiterandco.com/video/video-4-estimating-the-length-of-a-technology-or-software-explainer-video-for-a-budget/" content="Video 4: Estimating the length of a technology or software explainer video for a budget" /><meta itemprop="datePublished" content="2020-12-06" /><meta itemprop="dateModified" content="2021-01-30" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Studio Rossiter"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.rossiterandco.com/author/kevin-rossiter/" /><meta itemprop="name" content="Kevin Rossiter" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor.jpg" /><meta itemprop="width" content="1000" /><meta itemprop="height" content="562" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>
	
					<a class="pp-post-link" href="https://www.rossiterandco.com/video/video-4-estimating-the-length-of-a-technology-or-software-explainer-video-for-a-budget/" title="Video 4: Estimating the length of a technology or software explainer video for a budget"></a>
		
		
		
					<div class="pp-content-grid-image pp-post-image">
    					<div class="pp-post-featured-img">
				<div class="fl-photo fl-photo-align-center" itemscope itemtype="https://schema.org/ImageObject">
	<div class="fl-photo-content fl-photo-img-jpg">
				<img loading="lazy" class="fl-photo-img wp-image-18557 size-medium" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor-700x393.jpg" alt="Video 4: Estimating the length of a technology or software explainer video for a budget" itemprop="image" data-no-lazy="1" height="393" width="700" title="Video-4-Estimating-the-length-compressor" srcset="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor-700x393.jpg 700w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor-768x432.jpg 768w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor-339x191.jpg 339w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" />
					</div>
	</div>
			</div>
		    
			
		
			</div>
		
		<div class="pp-content-grid-inner pp-content-body clearfix">
			
			
			<div class="pp-content-post-data">
									<h3 class="pp-content-grid-title pp-post-title" itemprop="headline">
														Video 4: Estimating the length of a technology or software explainer video for a budget											</h3>
									
				
				
				
				
				
				
				
				
			</div>
			
					</div>

			</div>

<div class="pp-content-post pp-content-grid-post pp-post-2n pp-grid-style-3 post-18570 post type-post status-publish format-standard has-post-thumbnail hentry category-video tag-animated-demo-cost tag-infographic-video-cost tag-software-video-style tag-technology-video-style tag-video-budget" itemscope itemtype="https://schema.org/BlogPosting" data-id="18570">

	<meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.rossiterandco.com/video/video-3-choosing-a-technology-or-software-explainer-video-style-to-match-your-budget/" content="Video 3: Choosing a technology or software explainer video style to match your budget" /><meta itemprop="datePublished" content="2020-12-05" /><meta itemprop="dateModified" content="2021-01-30" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Studio Rossiter"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/08/Studio-rossiter-logo-grey.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.rossiterandco.com/author/kevin-rossiter/" /><meta itemprop="name" content="Kevin Rossiter" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor.jpg" /><meta itemprop="width" content="1000" /><meta itemprop="height" content="562" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>
	
					<a class="pp-post-link" href="https://www.rossiterandco.com/video/video-3-choosing-a-technology-or-software-explainer-video-style-to-match-your-budget/" title="Video 3: Choosing a technology or software explainer video style to match your budget"></a>
		
		
		
					<div class="pp-content-grid-image pp-post-image">
    					<div class="pp-post-featured-img">
				<div class="fl-photo fl-photo-align-center" itemscope itemtype="https://schema.org/ImageObject">
	<div class="fl-photo-content fl-photo-img-jpg">
				<img loading="lazy" class="fl-photo-img wp-image-18556 size-medium" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor-700x393.jpg" alt="Video 3: Choosing a technology or software explainer video style to match your budget" itemprop="image" data-no-lazy="1" height="393" width="700" title="Video-3-Choosing-a-technology-compressor" srcset="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor-700x393.jpg 700w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor-768x432.jpg 768w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor-339x191.jpg 339w, https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" />
					</div>
	</div>
			</div>
		    
			
		
			</div>
		
		<div class="pp-content-grid-inner pp-content-body clearfix">
			
			
			<div class="pp-content-post-data">
									<h3 class="pp-content-grid-title pp-post-title" itemprop="headline">
														Video 3: Choosing a technology or software explainer video style to match your budget											</h3>
									
				
				
				
				
				
				
				
				
			</div>
			
					</div>

			</div>

								<div class="pp-grid-space"></div>
				
					</div>

		<div class="fl-clear"></div>

		
				
		</div><!-- .pp-content-posts -->
	
	</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
</div>	</div><!-- .fl-post-content -->

	
	<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.rossiterandco.com/video/" rel="category tag">Video</a> and tagged <a href="https://www.rossiterandco.com/tag/intro-video/" rel="tag">intro video</a></div></div>		
</article>


<!-- .fl-post -->
			

		</div>
		
		<div class="fl-sidebar fl-sidebar-right fl-sidebar-display-desktop col-md-4" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="recent-posts-widget-with-thumbnails-2" class="fl-widget recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
<h4 class="fl-widget-title">RECENT POSTS</h4>
	<ul>
		<li><a href="https://www.rossiterandco.com/video/what-does-a-software-demo-video-cost/"><img width="75" height="75" src="https://www.rossiterandco.com/wp-content/uploads/2021/01/how-to-figure-out-your-software-demo-video-cost-compressor-150x150.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="How to figure out your software demo video cost" loading="lazy" /><span class="rpwwt-post-title">How to figure out your software demo video cost</span></a></li>
		<li><a href="https://www.rossiterandco.com/video/video-5-bringing-your-technology-or-software-explainer-video-cost-estimates-together/"><img width="75" height="75" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-5-Bringing-together-compressor-150x150.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Video 5: Bringing your technology or software explainer video cost estimates together" loading="lazy" /><span class="rpwwt-post-title">Video 5: Bringing your technology or software explainer video cost estimates together</span></a></li>
		<li><a href="https://www.rossiterandco.com/video/video-4-estimating-the-length-of-a-technology-or-software-explainer-video-for-a-budget/"><img width="75" height="75" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-4-Estimating-the-length-compressor-150x150.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Video 4: Estimating the length of a technology or software explainer video for a budget" loading="lazy" /><span class="rpwwt-post-title">Video 4: Estimating the length of a technology or software explainer video for a budget</span></a></li>
		<li><a href="https://www.rossiterandco.com/video/video-3-choosing-a-technology-or-software-explainer-video-style-to-match-your-budget/"><img width="75" height="75" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-3-Choosing-a-technology-compressor-150x150.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Video 3: Choosing a technology or software explainer video style to match your budget" loading="lazy" /><span class="rpwwt-post-title">Video 3: Choosing a technology or software explainer video style to match your budget</span></a></li>
		<li><a href="https://www.rossiterandco.com/video/video-2-technology-or-software-explainer-video-calculating-goals-budgets/"><img width="75" height="75" src="https://www.rossiterandco.com/wp-content/uploads/2020/12/Video-2-calculating-goals-budgets-compressor-150x150.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Video 2: Technology or software explainer video - calculating goals &amp; budgets" loading="lazy" /><span class="rpwwt-post-title">Video 2: Technology or software explainer video &#8211; calculating goals &#038; budgets</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>	</div>
		
	</div>
</div>



	</div><!-- .fl-page-content -->
		</div><!-- .fl-page -->
		<div class="searchwp-modal-form" id="searchwp-modal-652ea0d21b1427a1bfa685e40d9bc1de" aria-hidden="true">
			
<div class="searchwp-modal-form-default">
	<div class="searchwp-modal-form__overlay" tabindex="-1" data-searchwp-modal-form-close>
		<div class="searchwp-modal-form__container" role="dialog" aria-modal="true">
			<main class="searchwp-modal-form__content">
				<form aria-label="Search" method="get" role="search" action="https://www.rossiterandco.com/" title="Type and press Enter to search.">

	<input aria-label="Search" type="search" class="fl-search-input form-control" name="s" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" />
<button>Search</button>
<input type="hidden" name="swpmfe" value="652ea0d21b1427a1bfa685e40d9bc1de" /></form>
			</main>
			<footer class="searchwp-modal-form__footer">
				<button class="searchwp-modal-form__close button" aria-label="Close" data-searchwp-modal-form-close></button>
			</footer>
		</div>
	</div>
</div>

<style type="text/css">
	/* ************************************
	 *
	 * 1) Overlay and container positioning
	 *
	 ************************************ */
	.searchwp-modal-form-default .searchwp-modal-form__overlay {
		background: rgba(45, 45, 45 ,0.6);
		position: fixed;
		top: 0;
		left: 0;
		right: 0;
		bottom: 0;
		display: flex;
		justify-content: center;
		align-items: center;
		z-index: 9999990;
	}

	.searchwp-modal-form-default .searchwp-modal-form__container {
		width: 100%;
		max-width: 500px;
		max-height: 100vh;
	}

	.searchwp-modal-form-default .searchwp-modal-form__content {
		background-color: #fff;
		padding: 2em;
		border-radius: 2px;
		overflow-y: auto;
		box-sizing: border-box;
		position: relative;
		z-index: 9999998;
	}




	/* **************************************
	 *
	 * 2) WordPress search form customization
	 *
	 ************************************** */
	.searchwp-modal-form-default .searchwp-modal-form__content .search-form {
		display: flex;
		align-items: center;
		justify-content: center;
	}

	.searchwp-modal-form-default .searchwp-modal-form__content .search-form label {
		flex: 1;
		padding-right: 0.75em; /* This may cause issues depending on your theme styles. */

		/* Some common resets */
		float: none;
		margin: 0;
		width: auto;
	}

	.searchwp-modal-form-default .searchwp-modal-form__content .search-form label input {
		display: block;
		width: 100%;
		margin-left: 0.75em;

		/* Some common resets */
		float: none;
		margin: 0;
	}

	.searchwp-modal-form-default .searchwp-modal-form__footer {
		padding-top: 1em;
	}

	.searchwp-modal-form-default .searchwp-modal-form__close {
		line-height: 1;
		display: block;
		margin: 0 auto;
		background: transparent;
		border: 0;
		padding: 0.4em 0.5em;
	}

	.searchwp-modal-form-default .searchwp-modal-form__close:before {
		content: "\00d7";
		font-size: 2em;
	}




	/* ******************************************
	 *
	 * 3) Animation and display interaction setup
	 *
	 ***************************************** */
	@keyframes searchwpModalFadeIn {
		from { opacity: 0; }
		to { opacity: 1; }
	}

	@keyframes searchwpModalFadeOut {
		from { opacity: 1; }
		to { opacity: 0; }
	}

	@keyframes searchwpModalSlideIn {
		from { transform: translateY(15%); }
		to { transform: translateY(0); }
	}

	@keyframes searchwpModalSlideOut {
		from { transform: translateY(0); }
		to { transform: translateY(-10%); }
	}

	.searchwp-modal-form {
		display: none;
	}

	.searchwp-modal-form.is-open {
		display: block;
	}

	.searchwp-modal-form[aria-hidden="false"] .searchwp-modal-form-default .searchwp-modal-form__overlay {
		animation: searchwpModalFadeIn .3s cubic-bezier(0.0, 0.0, 0.2, 1);
	}

	.searchwp-modal-form[aria-hidden="false"] .searchwp-modal-form-default .searchwp-modal-form__container {
		animation: searchwpModalSlideIn .3s cubic-bezier(0, 0, .2, 1);
	}

	.searchwp-modal-form[aria-hidden="true"] .searchwp-modal-form-default .searchwp-modal-form__overlay {
		animation: searchwpModalFadeOut .3s cubic-bezier(0.0, 0.0, 0.2, 1);
	}

	.searchwp-modal-form[aria-hidden="true"] .searchwp-modal-form-default .searchwp-modal-form__container {
		animation: searchwpModalSlideOut .3s cubic-bezier(0, 0, .2, 1);
	}

	.searchwp-modal-form-default .searchwp-modal-form__container,
	.searchwp-modal-form-default .searchwp-modal-form__overlay {
		will-change: transform;
	}
</style>
		</div>
		<script src='https://www.rossiterandco.com/wp-content/plugins/bbpowerpack/assets/js/isotope.pkgd.min.js?ver=3.0.1' id='jquery-isotope-js'></script>
<script src='https://www.rossiterandco.com/wp-content/uploads/bb-plugin/cache/19357-layout.js?ver=b21e403d0406995e898ce84e5449297f' id='fl-builder-layout-19357-js'></script>
<script id='bellows-js-extra'>
var bellows_data = {"config":{"landingpageonly":{"folding":"multiple","current":"off"},"main":{"folding":"single","current":"on"}},"v":"1.2.1"};
</script>
<script src='https://www.rossiterandco.com/wp-content/plugins/bellows-pro/assets/js/bellows.min.js?ver=1.2.1' id='bellows-js'></script>
<script src='https://www.rossiterandco.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script id='megamenu-js-extra'>
var megamenu = {"timeout":"300","interval":"100"};
</script>
<script src='https://www.rossiterandco.com/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.2' id='megamenu-js'></script>
<script src='https://www.rossiterandco.com/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js?ver=2.4.2' id='jquery-throttle-js'></script>
<script src='https://www.rossiterandco.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.4.2' id='jquery-magnificpopup-js'></script>
<script src='https://www.rossiterandco.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.7.7' id='bootstrap-js'></script>
<script id='fl-automator-js-extra'>
var themeopts = {"medium_breakpoint":"992","mobile_breakpoint":"768"};
</script>
<script src='https://www.rossiterandco.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.7.7' id='fl-automator-js'></script>
<script src='https://www.rossiterandco.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script src='https://www.rossiterandco.com/wp-content/plugins/searchwp-modal-search-form/assets/dist/searchwp-modal-form.min.js?ver=0.3.4' id='searchwp-modal-form-js'></script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-T43GPZP"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->      
<script type="text/javascript" id="cookieinfo"
	src="//cookieinfoscript.com/js/cookieinfo.min.js"
	data-bg="#645862"
	data-fg="#FFFFFF"
	data-link="#F1D600"
	data-cookie="CookieInfoScript"
	data-text-align="left"
    data-close-text="Got it!"
    data-moreinfo="https://www.rossiterandco.com/privacy-policy/">
</script>

<script type="text/javascript">!function(e,t,n){function a(){var e=t.getElementsByTagName("script")[0],n=t.createElement("script");n.type="text/javascript",n.async=!0,n.src="https://beacon-v2.helpscout.net",e.parentNode.insertBefore(n,e)}if(e.Beacon=n=function(t,n,a){e.Beacon.readyQueue.push({method:t,options:n,data:a})},n.readyQueue=[],"complete"===t.readyState)return a();e.attachEvent?e.attachEvent("onload",a):e.addEventListener("load",a,!1)}(window,document,window.Beacon||function(){});</script> <script type="text/javascript">window.Beacon('init', '13df486a-cfd5-49b4-8531-956e14d40dfd')</script>



</body>
</html><!-- WP Fastest Cache file was created in 0.64145088195801 seconds, on 05-02-21 14:27:07 -->